Troubleshooting

Technical requirements

Our products require a modern web browser with an Internet connection to use them, you can find below the required and preferred versions. You don’t need any browser plugin or installed software, Melody Scanner only uses standard HTML5 technologies. If you use a device with android, Melody Scanner is also available as a native app […]

Still not on Melody Scanner? Create a free account today!
Register Now